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Chapter 1 Description 

 

Description 

  
Application The software migration tool SMT is intended for updating software and backing up 

the AO2000 gas analyzer configuration files. 

  
Versions SMT is available as a full version and a basic version. 

  
Full Version The “SMT” full version offers complete functionality. 

  

 

CAUTION! 

We strongly recommend obtaining training from ABB Analytical prior to using 
the full version of SMT. The risks of improper use include damaging or 
destroying the AO2000 gas analyzer configuration. 

  
Basic Version The “SMT Light” basic version has reduced functionality compared to the full 

version. It is contained on the free CD-ROM that is supplied as standard 
equipment with an AO2000 gas analyzer. 

  
Function SMT SMT Light 

Software Update X X 1) 
Configuration file   

Save (Backup) X X 
Replace Serial Number X X 
Load X X 

System Overview   
Display, Print and Save (Backup) X X 
Tree View X – 
Function Block Navigation X – 

Log Content Backup X X 

Functionality 

Load a text file for user interface X X 
 
 1) “SMT Light” allows an update only from Software Version 2.0 or 3.0 to 

Software Version 4.0 (see page 11). 

  
Communications An Ethernet connection (peer-to-peer or network) is used for communication with 

the AO2000 central unit (see page 7). 

  
Language SMT is only available in an English language version. 
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Chapter 2 Installation 

 

System Requirements 

  
Computer 
Requirements 

• Windows NT (≥ 4.0) or Windows 2000 or Windows XP operating system 
• Minimum of 16 MB free memory (RAM) 
• Minimum of 10 MB free hard disk space 
• CD-ROM Drive 
• Ethernet interface 
• Ethernet connection with TCP/IP protocol 

  
User Knowledge The user should be familiar with the operation of Windows NT or Windows 2000 

or Windows XP. 

  

 

Install SMT 

  
Uninstall Other 
Program Versions 

Before installing SMT or SMT Light, uninstall the old program version. 
 
Before installing the full version, uninstall the basic version. 

  
Step Action 

1 Insert the CD-ROM with the SMT or SMT Light program. 
2 Run the “smt.exe” or “smtl.exe” file. 

Follow the instructions of the installation program. 

Install SMT 

3 

 
Accept the recommendation of the installation program for the 
name of the folder in which SMT or SMT Light shall be installed. 
All software tools are installed in this folder by default. 

  



 

42/24-25 EN Rev. 3 SMT Operator’s Manual 5 

Setting TCP/IP Parameters in AO2000 

  
Setting TCP/IP Para-
meters in AO2000 

The TCP/IP parameters in AO2000 have to be checked and changed if necessary 
for proper operation of SMT. 

  
Menu Path in AO2000 MENUE → Configure → System → Network → TCP/IP Network 

  
Point-to-Point 
Connection 

The IP address of AO2000 is factory-set to 192.168.1.1 (see Figure 1). When using a 
point-to-point connection the IP address in AO2000 must be harmonized with the 
setting in the PC (see “Setting TCP/IP Parameters in the PC”, page 6). 

  
Figure 1 
 
TCP/IP Settings  
for a Point-to-Point 
Connection 

 

  
Network Connection The parameters to be set depend on the DHCP (Dynamic Host Configuration 

Protocol) setting: 
 
DHCP on: Device name (max. 20 characters, no blanks and special characters), 
DHCP off: IP address, IP address mask und IP gateway address. 
 
If an Ethernet board is installed in the gas analyzer in addition to the standard 
Ethernet interface, the DHCP settings diverge as follows: 
 
DHCP1: Standard Ethernet interface, 
DHCP2: Ethernet board. 

  
Addresses The IP address, IP address mask and IP gateway address must be obtained from 

the system administrator. 
 

 
• Addresses of TCP/IP classes D and E are not supported. 
 
• The address bits that can be varied through the address mask cannot all be set 

to 0 or 1 (broadcast addresses). 

  



 

6 SMT Operator’s Manual 42/24-25 EN Rev. 3 

Setting TCP/IP-Parameters in the PC 

  
Point-to-Point 
Connection 

When using a point-to-point connection enter the IP address and subnet mask in 
the Internet Protocol Properties according to Figure 2. 
 
The IP address of AO2000 is factory-set to 192.168.1.1 (see “Setting TCP/IP 
Parameters in AO2000”, page 5). 

  
Figure 2 
 
TCP/IP Properties  
for a Point-to-Point 
Connection 

 

  
Network Connection When using a network connection ask the system administrator for the IP address, 

subnet mask and IP gateway address and enter these data likewise in the Internet 
Protocol Properties. 
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Ethernet Connection 

  
• Point-to-point connection: Twisted-pair cable with RJ45 plugs,  

pin configuration: 1–3, 3–1, 2–6, 6–2 
Versions and 
Required Cables 

• Connection via an Ethernet network: Twisted-pair cable with RJ45 plugs 
 

 
Cables are standard Ethernet cables and are not delivered with SMT or AO2000. 

  
Test the Ethernet 
Connection 

In order to test the Ethernet connection enter “ping IP address” (where IP address 
is the IP address of AO2000) in “Start → Run...”. 
 
In case of a working connection the gas analyzer should prompt with “Reply from 
IP address: bytes=32 time<10ms TTL=255” (the numbers are device specific). 
 
If you get the following prompt “Request timed out” the network connection is not 
working properly. Please consult your system administrator. 

 

 
The network name can be entered instead of the IP address. 
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Chapter 3 Operation 

 

Configure SMT 

  
Enter the Device 
Address 
 

 
 

 
Enter the gas analyzer’s IP address or network name in the “Configuration → Set 
connection address” menu (see also the “Setting TCP/IP Parameters in AO2000” 
section, page 5). 
 
The device address entered is displayed on the status line. 

  
Set the Configuration 
File Name 
 

 

 
 
Enter the directory and name for the configuration file in the “Configuration → Set 
archive file name” menu. 
 
The configuration file is saved as an ASCII file. The file extension “.bin” is added 
automatically. 
 
The configuration file is accessed 

• when saving configuration data using the  
“Migration → Save configuration data” menu, see page 13 

• when loading configuration data using the following menus: 
“Migration →Load configuration data” menu, see page 13,  
“Tools → Replace serial number”, see page 14,  
“Tools → Logbook list”, see page 16. 

 
The configuration file name is displayed on the status line. 

 
Continued on next page 
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Configure SMT, continued 

  
Set the User Interface 
Language 
 

 

 
 
The “Configuration → Set language file” menu is used to enter the name of the 
text file containing the two gas analyzer user interface languages that will be 
loaded in the gas analyzer when performing an update. 
 
If no selection is made, the language combination loaded and the language 
selected on the gas analyzer will remain in effect. 
 
The text file name is displayed on the status line.  

  
Language Combination File Name 

German – Dutch AOTextD_NL 
English – Brazilian Portuguese AOTextGB_BR
English – German AOTextGB_D 
English – Spanish AOTextGB_E 
English – French AOTextGB_F 
English – Italian AOTextGB_I 

Available Language 
Combinations 

English – Dutch AOTextGB_NL

  

 
To load a text file without updating the gas analyzer, use the “Change language” 
tool, see page 15. 

  
Status Line The “View → Status bar” menu allows a status line at the lower edge of the screen 

to be displayed or hidden. 

  
Error List The “View → Error List” menu allows an error list to be displayed in the lower 

portion of the window or hidden. 
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Perform Update 

  
Software Versions “SMT” allows the update from software version 2.0.w or 3.0.x or 4.0.y to software 

version 4.0.z. 
 
“SMT Light” allows the update only from software version 2.0.x or 3.0.y to software 
version 4.0.z (see page 11). 

  
Perform Update 
 

 

 
 

Step Action 

1 Select the “Migration → Update software” menu. 
Click the “Yes” button in the dialog box that appears. The update will 
automatically run in three steps: 
1 Saving configuration data from AO2000 in the file selected using 

the “Configuration → Set archive file name” menu (see page 8). 
2 Booting AO2000, loading system software, rebooting. 

2 

3 Loading configuration data from the selected file into AO2000; 
saving the configuration in AO2000. 

  
Perform Step-by-Step 
Update 

The update can also be performed in a step-by-step manner. Thereby the following 
sequence must be observed. 

 
Step Action Explanation 

1 “Save configuration data” Saving configuration data 
2 “Load new software” Loading system software 
3 “Load configuration data” Loading and saving configuration data 

in AO2000 

  

 

CAUTION! 
 
The “Load new software” function overwrites the AO2000 configuration data. 

  

 
After an update, check the AO2000 autocalibration parameters and time zone, 
date and clock values. 
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Update from Software Version 2.0 to Software Version 4.0 

  
Hardware 
Requirements 

• Software version 4.0 can be installed only in a gas analyzer equipped with 
Syscon II. 

• In a gas analyzer with Syscon II and software version 4.0 
• maximum 3 IO boards can be installed in slots X11 to X13; 
• at least 1 analog output module and 1 digital I/O module must be installed; 
• the number of analog I/O boards must be equal to or greater than before 

conversion and update; 
• the total number of digital I/O boards and modules must be greater than 

before conversion and update. 

• I/O boards not used anymore in the gas analyzer with Syscon II and software 
version 4.0 must be deleted from the old gas analyzer (Syscon I, V 2.0) prior to 
conversion and update. 

• If instead of the present I/O boards other I/O boards shall be installed in the gas 
analyzer after conversion to Syscon II, the serial numbers must be changed 
before the update (see “Replace the Serial Number in a Configuration File”, 
page 14). 

  
I/O Boards and  
I/O Modules  
Default Assignment  

• First, the analog I/O boards are assigned to slots X11 to X13. 

• Subsequently, the digital I/O boards are assigned to further free slots. 

• Surplus I/O boards are assigned to “external” slots. 

• Digital I/O modules can be assigned also to digital I/O boards. 

  
Update from 
Software Version 2.0 
to  
Software Version 4.0 

The update from software version 2.0 to software version 4.0 is also possible 
using the “SMT Light” program version. 
 
The update must be performed in a step-by-step manner. 

 
Step Action 

1 “Migration → Save configuration data”: Save configuration data of 
(old) software version 2.0. 

2 Convert gas analyzer from Syscon I to Syscon II. 
3 “Migration → Load new software”: Load new software version 4.0. 

 
Continued on next page 
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Update from Software Version 2.0 to Software Version 4.0, continued 

  
Step Action 

4 “Migration → Load configuration data”: The “I/O Module Assignment” 
dialog appears. 

 In the “I/O Boards” list (left) the Syscon I/O’s and I/O boards as in the 
V 2.0 configuration file saved in step 1 are displayed. 
In the “Assignment” list (middle) the (new) I/O modules and I/O boards 
on Syscon II (V 4.0) as assigned to the Syscon I/O’s or old I/O boards 
by SMT are displayed. Modules assigned to each other are displayed 
in the same row. 
In the “Available” list (right) the I/O boards and I/O modules which are 
not assignable are displayed. 

5 Click “OK” to accept the assignment. The configuration file will be 
loaded into AO2000. 
Click “Cancel” to abort the update. The configuration file will not be 
loaded into AO2000. 
Click “Print” to save the module assignment in an ASCII file. 
Perform steps 6 to 9 to change the assignment: 

6 1 Select the I/O module in the “Assignment” panel whose 
assignment shall be canceled. 

2 Move the I/O module with “→” into the “Available” panel. 
7 1 Select the I/O module in the “Available” panel which shall be 

assigned instead. 
2 Select the old I/O module in the “I/O Boards” panel which the new 

module shall be assigned to. 
3 Move the new I/O module with “←” into the “Assignment” panel. 

8 Repeat steps 6 and 7 for each I/O module whose assignment shall be 
changed. 

9 Click “OK” to accept the changed assignment. The configuration file 
will be loaded into AO2000. 
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Save the Configuration File 

  
Saving the 
Configuration File 

 
 

Step Action 

1 Select the name of the configuration file in the “Configuration → Set 
archive file name” menu (see page 8).  

2 Select the “Migration → Save configuration data” menu. 
3 Click “Yes” in the dialog box. The configuration file is saved. 

  

 

Load the Configuration File 

  
Loading the 
Configuration File 

 
 

Step Action 

1 Select the name of the configuration file in the “Configuration → Set 
archive file name” menu (see page 8).  

2 Select the “Migration → Load configuration data” menu.  
3 Click “Yes” in the dialog box. The configuration file is loaded in the 

gas analyzer. 
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Replace the Serial Number in a Configuration File 

  
“Replace serial 
number” Tool 
 

 

 
 
The configuration data from a gas analyzer can be transferred to a different gas 
analyzer using the “Replace serial number” tool. 
 
The serial number of a system module can be changed in a saved configuration 
file. The modified configuration file can be loaded into a gas analyzer.  

  

 

CAUTION! 

The applicable system module (analyzer module or I/O board) type and 
configuration must be absolutely identical in the configuration file and gas 
analyzer. Otherwise the gas analyzer configuration can be damaged or 
destroyed.  

  
Step Action 

1 Make a backup copy of the configuration file before proceeding. 
2 Select the name of the configuration file in the “Configuration → Set 

archive file name” menu (see page 8). 
3 Select the “Tools → Replace serial number” menu. 
4 Select the serial number to be changed in the “System Modules Serial 

Number” field. 
5 Replace the serial number in the “Replace specified serial number” 

field. 
6 Use “Set” to enter the changed serial number in the configuration file. 
7 Close the dialog box by clicking “OK”; this will save the changes to 

the configuration file. 
8 Load the modified configuration file in the gas analyzer using 

“Migration → Load configuration data” (see page 13). 

Procedure 

9 For additional gas analyzer hardware, the gas analyzer configuration 
must be changed after the configuration file is loaded. 
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Load a Text File 

  
“Change language” 
Tool 
 

 

 
 
The “Change language” tool is used to load into a gas analyzer a text file 
containing two languages for the user interface. 
 
By default, German and English are loaded into the gas analyzer. 

  
Language Combination File Name 

German – Dutch AOTextD_NL 
English – Brazilian Portuguese AOTextGB_BR
English – German AOTextGB_D 
English – Spanish AOTextGB_E 
English – French AOTextGB_F 
English – Italian AOTextGB_I 

Available Language 
Combinations 

English – Dutch AOTextGB_NL

  
Step Action 

1 Select the “Tools → Change language” menu. 

2 Use the “Browse” button to select a text file (AO TextGB_F containing 
English and French in the example above). 

Use the “Check from AO” button to display the languages currently in 
the gas analyzer (English and German  in the example above). 

3 

 
If the length of any text in the file differs from that loaded in the 
gas analyzer an message appears and any text with a different 
lengths is displayed in an list at the bottom of the window. 

Procedure 

4 Load the selected text file in the gas analyzer using the “Load Text 
File” button. 
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Output Log Contents 

  
“Logbook list” Tool 
 

 

 
 
The “Logbook list” tool is used to save the contents of a gas analyzer or con-
figuration file log as text (logbook listing); in this format it can be processed using 
MS Excel. Additionally, the log can be viewed on the screen. 

  
Step Action 

Save log as text file 
1 To save the AO2000 log: Set the AO2000 IP address using the 

“Configuration → Set connection address” menu (see page 8).  
To save the log from a configuration file: Select the name of the 
configuration file in the “Configuration → Set archive file name” menu 
(see page 8). 

2 Select either “Logbook from AO device” or “Logbook from archive 
file” in the “Tools → Logbook list” menu. Select “View Report” to 
display the log on screen. 

3 Use the “Browse” button to select a file name or enter the name of the 
file to which the log is to be saved. 

4 Save the log as a text file using the “OK” button. 

Open text file in MS Excel 
1 Open the saved text file in MS Excel. The Text Assistant is auto-

matically started. 
2 In step 1 select the default settings by clicking “Continue”. 
3 In step 2 select “Tab” and “{none}” as text delimiters. Click the 

“Continue” button. 
4 In step 3, in “Preview Marked Data”, mark all columns and select 

“Text” as the data format. Click the “Finish” button. 

Procedure 

5 The logbook listing will be displayed in sequence, sorted from most 
recent to oldest entries. In the “Status” column, appearing messages 
are marked with “+”, canceled messages with a “-” and informational 
messages with “+-”. Acknowledged messages are shown with a “q” 
following the status symbol. 
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System Overview 

  
“System overview” 
Tool 
 

 

 
The “System overview” tool has the following functions: 

• Display the system overview (including navigation using links, see page 18), 

• Print the system overview, 

• Save the system overview as an ASCII file. 

  

 
The “System overview” can only display a view of the connected gas analyzer;  
it cannot display the contents of a saved system overview file. 

 
 The tree view and navigation capabilities are only found in the full version of SMT. 

 
Continued on next page 
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System Overview, continued 

  
Step Action 

1 Set the AO2000 IP address using the “Configuration → Set 
connection address” menu (see page 8).  

2 Display the system overview: Select the “Tools → System overview” 
menu. A tree view is displayed in the left pane. The right pane shows 
the details of the element selected in the tree view. 

 Save the system overview: Select the “File → Save as” menu and 
enter or select the file name in which the system overview is to be 
saved. 

Procedure 

 
Print the system overview: Select the “File → Print” menu. 
A print preview is possible using the “File → Print preview” menu. 
The “Print” and “Print preview” commands are only available if the 
cursor is in the tree view pane. 
Use the “Options → Printer font” menu to select the printer font to be 
used for print output. This setting also applies to the print preview. 

  
Navigating in the 
System Overview 

The detail view of most elements contains linked fields that are shown in white. 
Clicking on one of these fields brings up the detail view of the element selected. 
 
Example 1: 
The system overview detail view contains lists of analyzer modules and I/O 
modules. Clicking on these names brings up the detail view of the analyzer 
module selected. 
 
Example 2: 
The function block detail view has the input and output fields linked. Double-
clicking one of these fields brings up the detail view of any function block 
associated with this input or output. 

  
Profibus Functions Details... The Profibus map is displayed on the screen. 

Save... The Profibus map is saved into a text file. This file can be edited 
using e.g. Microsoft Excel. 

Print The Profibus map is output on a printer. 
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